Project

General

Profile

Bug #1045

Quasselcore crashes after trying to send a message in a query where a blowfish key has been set

Added by brot almost 7 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel Core
Target version:
Start date:
01/31/2011
Due date:
% Done:

0%

Version:
0.7-pre
OS:
Any

Description

The Quasselcore crashes when one tries to send a message to a query where a blowfish encryption key has been set with "/setkey mumu" (or any other key)

This behaviour is always reproducable. Even after i recompiled QCA and the Quasselcore with the same Qt version, the problem persists.

1. open a query window with someone
2. /setkey secretkey
3. write something
4. core crashes

quasselcore_blowfishcrash_backtrace - backtrace of the core-crash (4.91 KB) brot, 01/31/2011 01:19 PM

quasselcore_blowfishcrash_backtrace2 - backtrace of the core-crash after qca and quasselcore have been compiled with the same qt version (4.99 KB) brot, 01/31/2011 01:19 PM

Associated revisions

Revision 393ac8b4 (diff)
Added by johu over 6 years ago

check for qca provider plugin, fixes #1045

Prevents core from crashing when qca provider plugin is missing.
The plugin is needed at runtime. Can occurres when packagers did
not install it.

Revision 90fba615 (diff)
Added by johu almost 6 years ago

check for qca provider plugin, fixes #1045

Prevents core from crashing when qca provider plugin is missing.
The plugin is needed at runtime. Can occurres when packagers did
not install it.

History

#1 Updated by johu almost 7 years ago

  • Status changed from New to Resolved

Cause is missing qca-ossl qt plugin on system. Needed for working blowfish encryption. See http://delta.affinix.com/qca/

#2 Updated by johu over 6 years ago

  • Target version set to 0.7.2

#3 Updated by johu over 6 years ago

It can only occure if packagers did not install qca-ossl. I added a small fix to prevent this bug see http://gitorious.org/quassel/quassel/merge_requests/122.

#4 Updated by johu over 6 years ago

  • Target version changed from 0.7.2 to 0.8.0

#5 Updated by johu over 6 years ago

  • Target version changed from 0.8.0 to 0.7.3

#6 Updated by johu about 6 years ago

  • Target version changed from 0.7.3 to 0.7.4

Also available in: Atom PDF